"An Error Occured And The File Couldn't be Written"

I can not save a new project. The following message appears: "an error occured and the file couldn't be written". Help me please. p.s. I use Linux Mint - 18.1

Haven't used Linux in many years, but try using the Save As option in the File menu as a different name. Check that you have the correct permissions to save to whatever directory path you have chosen if different from a previous path.

That's about it for me :)


I have reinstalled the BSS, but the error continues. I ask the development team to test on a Linux Mint computer. I installed BSS by terminal and also application manager, unfortunately does not save project.

Problem solved. I saved the project in the download folder and it worked.

Glad you got it worked out Wil, kind of strange if you can't tell it exactly where you want it to save your projects though. That works for me and I'm sure most others that use the app. Could be that maybe you didn't have the save location selected correctly or typed in correctly. I found it's much more efficient to browse to the folder you want to use rather than typing it so maybe that's all it was. It will give you save errors if you choose folders it cannot save to or if you typo the location.

I could not save the default folder: "bootstrap". Like I said, I switched to the download folder and it worked. Thanks for listening!

The problem is that it wants to saves files on /opt/bootstrapstudio folder, and usually regular users have no writing permissions on that folder, so generated files should saved somewhere in the /home/USER folder.