Are there prerequisites to create a component in library?

I’ve been a BSS user for a year and I just upgraded my license to Lifetime because I enjoyed the experience.
I’m not a user who uses a lot, but BSS helps me a lot to create a nice layout for my personal applications.
My actual version is 5.6.4.
In the last few days when designing a page that should be used on both, the notebook and the iPhone, I ran into a problem with “”. To isolate the problem, I started a new design to develop just part of the problem.
After two days of trying, trying, trying, I managed to solve it.
So I decided to create a component of this piece of canvas. Inside HTML/BODY, it’s a Container with 1 row and 2 columns, inside which I have only one Form with Button in each column, and a javascript to handle each Form.
Now I want to turn this container into a component to use in the main design.
I’m not getting.
When selecting the Container and clicking “Add to Library”, the only item that is available to include in the Library is javascript.
Thanks in advance

Post a screenshot of what you’re seeing in the dialogue box

Good morning Print Ninja. Thanks for your interest.
Yesterday I have tested this combination of components in with Bootstrap 4.6 too, and the same occurs.

I hope this helps.

@carliedu Thank you for the screenshots. What you are showing is what’s supposed to happen - the component is added to your library and you can optionally add the JS file.

The app doesn’t check the JS by default because we don’t inspect the JS to see if it’s used. This isn’t even possible to do reliably.

Thanks for your answer Martin.
My problem is not with the javascript. This is not important.
The problem is that html and css are not included. Why?

Can you send us the design that’s causing the problem via email?

Sure, no problem.
You can get it at BootstrapStudio/lixo_v5.bsdesign at main · carliedu/BootstrapStudio · GitHub

Worked fine for me, saved to library and imported to another document no problem.

I have also shared it online under the name lixo-v5 if that helps

You have to expand the sections (click the little triangles next to the words) so we can see what is being selected (or not selected.) Then post another screenshot.

Hi Richards and PrintNinja.
Thanks for your time.
I tested it now again and it worked very nice.
I realy don’t know what I was doing yesterday that it wasn’t working.
Sorry for your time.
This is resolved.

1 Like