Can't always close a project (Mac version)

I will have to test this next time I restart my computer and see if that’s when it happens. So far it’s 2 times, but both times on a fresh boot of the computer. I cannot close the first project. I was able to close the 2nd one I had open last time, but not the first.

This time I have only 1 project open and the “x” button on the tab lights up the red color when moused over, but will not function at all. Nothing is grayed out, it just doesn’t work. I have to close the program down and then (if it works as the last time did since I haven’t closed it yet) it will most likely start working as it should.

Let me know if you need the project. This was BSS4 today, and most likely was BSS5 last time, but I’m not 100% sure which project I was working on at the time. I just figured it was a fluke when it worked after I restarted so I wasn’t paying real close attention sorry.

Not at all sure “why” this happens, but I have narrowed it down to “only” on fresh boot of my Mac Mini. After I close the app and reopen it, it works fine and everything closes as it should.

Thank you for the report! We will investigate what could be causing it.

Just updating that I’ve also found that even if I open multiple projects, I can close all of the others except the first one opened. Just had that happen and figured I’d get that info in here too.


If I have multiple unsaved projects open and clicking the X to close one of them without to save that project the App wants to quit and the dialog, you have unsaved project shows up . Maybe it is related to not be able to close a project as @jo-r reported

If it is related it would probably mean that the ctrl+S to save isn’t working, which is what I use constantly. Definitely worth checking into, but it’s not something on my end that I would see as anything I close is already saved, and it’s strange that it would be only the original first project open for the day.

This even persists through a couple days of the computer not being rebooted. I hadn’t done anything the past couple days as we’ve had company, but today I went in and opened a project (as I said, I hadn’t booted the computer since Thursday morning. And …
It still happened lol. Project I opened would not close. I opened another and tested again and it closed just fine, and wouldn’t let me close the first project even with the 2nd one open so it’s tied to that first opened project like glue.

So today I am working on a remake of a big site and I went to close the project (it was the first and only one I had opened at this point) and it didn’t close, same as before, but I noticed a few things that I didn’t notice before.

  1. You can’t do anything with the project once you try to close it. I think it is kind of closing it or something and just gets stuck? not sure there, but it’s definitely not really open. Nothing responds when I click on it in the project after that.

  2. I was about to close the app when I thought maybe try to open another project and see what happens (this is what leads me to believe it’s actually closed sort of, maybe just not all the way visually or something). When I opened another project it replaced the one I had tried to close.
    I didn’t think far enough ahead to try closing that one before I closed the app. I’ll try to remember to do that next time, but I’m betting the 2nd project will close properly. Restarting the app does fix this as I mentiioned in a previous post.

Just a heads up that as of version 6.0 and 6.01 this issue is still there.

1 Like

So another little tidbit on this issue that happened yesterday. My power went out and although I Do have a backup battery to keep the computer running in case of power outages, I apparently didn’t have both monitors plugged into it, just one (will be remedying that today).

The outage yesterday resulted in my not being able to turn off BSS at all via the normal right click on the icon on my Dock (since the other monitor had the app open on it). I tried a bunch of times to shut it off with the right click and Exit option, but it just wouldn’t do it. I waited for about 5 minutes and finally had to fire up the Activity Monitor app and Force Close it.

I am not sure if this is all tied together or not, but figured I’d better report this in case it is. Sure hope something is found on this. Good Luck on it!

P.S. This seems to be “not” project specific as it happens with all projects of all BS versions. As always, don’t hesitate to ask if you need more info or files.

Just wanted to add that, I’m not sure what you did in this last update, but it “seems” to have fixed the closing of the projects taking forever or not closing. I’ll keep checking it, but so far so good!

In the last update, we fixed a bug that had to do with externally edited files. We are pretty sure that’s what was causing this issue, but report back if the problem persists :slight_smile:

1 Like