Can't open a project file on my Mac that someone created with Windows

You can see the reference here in this post:

Basically, the file downloads to my computer, double clicking the file will open BSS, but the file doesn't open ever. Tried doing it that way and doing it via the File menu to navigate to the file, but it won't open at all. No error messages, doesn't lock up, doesn't act like it's doing anything, just never opens.

I'm on a Mac and the OP of that post is on Windows, another person was able to open it just fine so I don't know what is happening here, but something isn't right somewhere I guess.

I'm having a similar issue. I created a new site from the templates. Customized it, then saved it into a site folder. I quit BSS, then moved that site folder to a different folder. No graphics had been imported, it was just the .bsdesign file. When I double-clicked the file to open, BSS opened just fine, then nothing happened. I also tried opening it from the menu bar. I'm on an iMac, system 10.14 (Mojave). Bootstrap Studio version 4.3.2

Sorry for replying so late. Can you test it in the newly released Bootstrap Studio 4.3.3? We implemented a change to the way designs are read from disk, so that double clicking should now work properly. If it still doesn't, you can send us the broken bsdesign files here.

Unfortunately I have since deleted the file since it wasn't something I needed, and the OP from the other post has removed it from being able to be downloaded. Guess if they repost again to let us know if it worked for them to clean the files off their server and reupload them fixed their issue or not, we can ask again for the file and see if it is still broken or not.