Editor gone crazy [fixed in 4.3.5]

I am experiencing issues editing the text inside a <p> with BSS editor behaving in a strange way. Backspace key deletes the entire paragraph and not just a letter, the first word is not editable and the space bar behaves strangely, moving to the right also the character at the left of the cursor. Even double clicking on a word doesn't select the word correctly. (Windows 10, can't tell if the bug is present also on mac)

a very simple bsdesign is here: http://ovh.to/8vhUnsR

The first <p> , the one with the drop cap shows the issue, editing the second works fine.

I'm on a mac and I haven't experienced what you're talking about at all, have others though that apparently no one else has that I posted a bit ago. Does restarting the app fix it? Usually fixes any of those visual anomalies for me. Sometimes just closing the project and reopening it does it too.

hi Jo, nope, I tried re-opening the bsdesign and its still reproducible (WIndows 10). The first paragraph, the one with the dropcap makes the editor work erratically. My guess is that the css code is causing the issue

enter image description here

. so that I can't use the backspace to delete letters, i'm unable to change the large L at the beginning of the paragraph, and when I double click a word it selects that wrongly too.

Wow yeah that's pretty messed up. Can you share your project with me so we can see if it does it on Mac as well? I've not seen anything like that at all. Most of my issues are selection issues in the preview window or visual issues that really aren't there, just there visually in the app and go away if I slide the screen size slider bigger just a bit from the default that it is when it first opens.

At least we can try to see if it's just on Windows or if it doesn't care what OS you're on for your issue.

@Jo you can download it here but it's really quick to test, just create a new design, paste

.dropcaps:first-of-type:first-letter {
  height: 0.7em;
  margin: 0.08em 0 -0.05em 0;
  padding: 0 0.065em 0 0;
  font-size: 5em;
  line-height: 0.85em;
  float: left;

inside your styles.css and add that class to a paragraph. On Windows you won't be able to use delete nor bacspace key, and it won't be easy to modify your paragraph. Especially the first huge letter.

enter image description here

Just confirmed this bug here too in Windows 10 BSS build 4.3.2 For me it does exactly what marrco is saying.

since I hope @martin reads this report, just one more request. Please, don't forget some of us are still waiting for the promised improvements. Including a better emmet-style editor (i'd prefer to use an external one like bracket or atom.io). So that I can type p*4>lorem to get four paragraphs of dummy text. or at least lorem50 in the text area to have a 50 words long sentence.

I feel idiotic having in 2018 to paste lorem ipsum from an external editor into BSS editor window because that feature is still unimplemented. This should be a tool aimed at web developers, so lorem ipsum is something we use daily,


Yep confirmed it here on Mac as well. I can add other paragraphs and edit them just fine it seems, just can't edit that one with the dropcap in it. I've never done one in BSS so hadn't come across this. I have a few sites I maintain in Wordpress (man I hate Wordpress lol) and I've done a couple in there, but not the same as in here I'm sure.

Anyways, confirmed it's messed up in Mac as well.

bug (easy to reproduce and confirmed) still not fixed in BSS build 4.3.3 nor 4.3.4

Sorry for the late reply in this thread. I can confirm the issue. Interestingly it appears to be a bug with contenteditable (the browser technology we use to make text editable within the app). An easy solution I can think of is to disable first-letter classes for the element that is being edited.

We just released 4.3.5 where we implemented the mentioned fix. :first-letter blocks are disabled while editing text. Everything should work as expected now.