HTML Title Won't Change

I use version 4.5.1 (latest at this moment). I have set custom title in Export Options >> Seo >> Main >> Title. However when i export & in preview, the title is not the same like i set.

Is it a bug?

Thank you.

If you right click the page in the Design panel and choose Properties, do you see your Title correctly? This is where you should be adding your titles (which should be unique for every page in your site.)

@printninja : i don't where to right click.

I am referring to main toolbar >> File >> Export Options >> Seo >> Main >> Title.

And i just notice that this bug happens only on a single project, which use "Landing Page" theme. On my other bootstrap studio project, i can change from the same toolbar (main toolbar >> File >> Export Options >> Seo >> Main >> Title)

Thank you.

On the lower right side of the screen, you will see the Design panel (the tab that says Design.) In that panel, you will see a heading called Pages. Expand that so you can see all the pages. Right click on any page and choose Properties from the pop-up menu. A window will open up called SEO settings, where you can the Page Title and Description. The SEO options available under the File > Export Options > SEO > Main > Title is (presumably) for a single page website.

Wow you are the man ! I've never known that trick before :-)

Thank you.

I’m currently having this issue but even after changing the SEO settings under Design for the page the title still does not change. Does anyone know what is causing this?

Go to the design panel in the lower right, go to Pages and right click the page you want to work on.

A menu will appear. Choose “Properties” from the menu.

A window will open with a column on the left. Choose SEO > main and then you can type in your page title and description in the appropriate fields. Click save when done. Do this for each page in your website.

You should keep your title length to under 70 characters (this includes spaces.) Your most important keywords should be first, as Google’s SEO algorithm weighs the importance of keywords from left to right (left being higher importance) Use commas for text, and “pipes” (this character | ) to separate concepts. Capitalize each word. (Google likes capitalized keywords.)

Your page description should be no more than 300 characters (with spaces.) Again, I like to capitalize every word. It makes the description stand out and look more “readable” on Google’s search results.