Links within List Items do not resolve when published

I'm not sure if this is a problem with new projects made since the latest update, but I have 2 published projects with lists that contain links to other pages within the project. These links are pointing to pages that have no domain. What is should be: What is happening: https://page-1.html/

As a work around, I'm having to move any links out of lists or set absolute URLs.

Thanks, Stu

I am having the same problem.

Please upload your site and give a link so we can see what's happening. It's very vague without any real details on what the code is doing.

Are these on your own server or are they being published in the BSS servers? This is also very important since they just did an major upgrade to the BSS servers so knowing that would help to know if it's possibly a server issue. All contexts use the 'link' component configured in exactly the same way (using the page select option to populate the link address), however the links in the list items and paragraphs have an extra forward slash. I have tried creating the links from scratch and the results are the same.

@sallen I have republished my project today under a new website and the problem doesn't seem to occur anymore. Can you confirm this on your side?

I'm afraid I'm still having the same problems. I even created a new project and re-created the same situation and published to a new bss site.

@sallen I have an instance of this problem in one place. But all other links work fine. I have tried to re-set them and each time it worked fine. One Link in the navbar is pointing to //index.html when published but the href attribute in the HTML panel is href="index.html".

Thanks for reporting this! It is indeed a bug on our side. It will be resolved in our next release.

Hi Gabriela,

I'm using Bootstrap Studio v4.3.1 and the bug is still present. Take a look at

BSS generated source code:

    <li><a href="//index2.html">URL = "index2.html"</a></li>
    <li><a href="///index2.html">URL = "/index2.html"</a></li>

"Settings > Export > Use Absolute Paths" is enabled.

Hope this info helps.




Any news on this bug?