Modal ID disappears after adding inner div class [fixed in 4.1.6]

When assigning an ID to the modal parent div container i.e

<div class="modal">

and adding a class to a inner div i.e

<div class="modal-content">

right after the ID created disappears. I notice this bug a while back but now that I'm making many changes to modals this has become very troublesome.

Replicating 1. Create modal component 2. Add an ID to modal parent container i.e

<div class="modal" id="someID">

  1. Add class to inner div ex:

    <

    div class="modal-content someClass">

right after you add this class look at the parent div ID and watch it disappear.

PS: I give up, can't get the last code example to wrap in {code}....

Specs

Mac OS High Sierra 10.13.3 Bootstrap Studio 4.1.5

Check to make sure you don't already have that ID on the page somewhere. You cannot add an ID more than once on a page in the app so usually what happens is it just ignores what you tried to add. That's most likely what's going on here.

Nope, I'm very aware how ID's work but thanks for the suggestion. Have you tried to replicate this bug @Jo?

I'm working with a fresh new BSS4 document, in fact here's a video to prove it.

https://streamable.com/iwf4t

In the video I made an ID Class with a red border and inner class with a blue border to visually show this issue.

Your video is tiny and you cannot see anything on it at that size. Might want to include a link to it rather than embedding it here so we can see it full size.

Regardless of the video (apparently the provided video host link embeds the video on these type of forums), have you verified this bug on your end?

Fixed video file: https://streamable.com/s/iwf4t/evyget

I can definitely verify this issue for sure, very strange. To add to this I hit Undo and when I did so it removed the class from the div and then put the ID back in place. If I hit Redo it then removes the ID again from the container and adds the class to the div. I pretty much did exactly as you outlined above with a model I dragged off the components and I added the class to the div that already had the "model-content" class in it.

Definitely something weird going on here!

I'm also going to verify that this does happen on a Win10Pro system.

Saj

Thanks @Jo and @Saj for testing, I was going crazy over this but glad I'm not the only one having this issue.

PS @Jo I'll find a video hosting solution, streamable is not showing my video clearly so apologies for that. Maybe I'll sign up to vimeo or youtube, noting for future posts.

Thank you for the video! I can reproduce this bug. We will fix it in the upcoming release.

This was fixed in Bootstrap Studio 4.1.6. You can upgrade to it right away.

Thanks Martin.