[Resolved] Using Paragraph or Header un-wanted letters appear when pressing space bar

I am using an intel-mac with the latest version of OSX. Also the latest version of BSS. When I insert a paragraph or header on a page and start editing the text I have noticed when I push the space bar that it responds with adding the text “fl” inside the control. I tried the same on my Windows 11 PC and it does not do this. Thoughts?

Thank you for the report! Does this occur when you try out the browser demo on our website: https://bootstrapstudio.io/

Hi. No, it does not mess up in the browser demo. It works fine there. It also works fine on my Windows 11 machine too.


Try in system preferences > accessibility > keyboard… and see if enable full keyboard access is unchecked

Although I don’t know why this would happen in just one program

Yes, that is un-checked and disabled. I am not sure how to enable it so I can check it and try it. I thought maybe it might have something weird between my bluetooth apple keyboard vs. the laptop keyboard but it doesn’t.

I think it being unchecked is correct. (Must admit my mac is stripped down and havn’t used it for a long time)

One thought, does it happen with certain fonts? Maybe its a font corruption.

1 Like

Interesting… I tried a different font (system font) and all is working. So, it must be something to do with the fonts I was using like you said. Arial Rounded to be exact. I converted it to woff using transfonter.org.

Great work narrowing the cause! It’s likely that the font requires some additional options passed to transfonter. Also does the Arial Rounded licensing permit it being converted to a web font?

Go to Manage webfonts… and search for “Varela Round”. It’s equal to Arial Rounded and there will be no display or licensing issues.

1 Like