Tabs - 'show' options is a bit buggy

HI BSS devs,

have been using your tab component but find that when i have been editing content within a tab that activating the options to add new tabs, show tabs etc is a bit buggy as does not always show in the tool bar.

i have found a way to work around this by closing BSS down and then reopening design but wanted to flag this bug

i am using latest version of mac osx

Interesting, because I have a different issue that surrounds the Show button. Mine always shows up though (the button that is), but what I have an issue with is that many times after editing some things in a tab, it will not allow me to show another tab. It used to be the situation where I could click outside of the area to another section of the page and it would then allow me to do it, but today I had to also restart the app to get it back to working again. I suppose I could probably load a different page and go back too, that would probably work as well, but it's definitely not what it should be doing.

That is roughly the same issue as I am facing Jo, glad it's not just me.

Thank you for opening this bug report! This is an interesting bug.

Normally the toolbars show depending on what element is selected. For the tabs, the toolbar is only shown if the tab pane or its direct child is selected, but not further down. So for example if you have a paragraph inside the tab-pane, and a span inside the paragraph, the toolbar won't show if the span is selected. We can increase the number of levels that cause the toolbar to show.

But reading about your experience it sounds like you are facing some other issue that I haven't seen myself. Any idea how this problem can be reproduced?

I will check further today and see if it is working as intended on my end. At one point on another site (using the same exact setup on a second site so of course it's happening on both of them) I was able to click somewhere else and it would then allow the Show button to be active again, but it's not doing it this time. This happens randomly on my end, or so I thought, but if a specific part of the element needs to be active that would explain why it wasn't working right for me.

I will test this further this afternoon or maybe this morning yet, and I'll let you know if it happens again even while doing things as you suggest by clicking on the tab pane rather than it's contents.

I have a similar issue with the content of an accordion control. Can't pin down what causes it but, as above, closing and restarting BSS fixes it. In my case, I have an extra button in the accordion header. When I first drag the button there, the Show/Hide buttons work fine. If I edit the text of the button, the Show/Hide buttons are disabled, not just for that accordion item but for all the others further down.

I'm using the Paper theme in case that's relevant.

I sincerely apologize for this taking so long, but I haven't had a lot of time for experimenting until now (while I'm still "technically" on vacation and just got home to play with it lol). I blame the holidays for my slacking hahaha!

It just did it to me again and I cannot find any way to actively reproduce it, but I can say it doesn't matter what I click on in the Overview tree, or the HTML pane or the Visual preview, it will not bring up the ability to show/hide at all. It was working just a short bit ago (within the past half hour) and just now will not do it. The only edit information I get at the top now is for adding columns and rows, no matter what I click on or try.

As always, restarting the app fixes the issue, but I sure wish I could give you more information on what may be causing it. Unfortunately I can see nothing obvious that could be doing so. Here's a recap of all the little things I was doing while I was editing things on a project. Might help at some point at least:

I'm on a Mac of course and I have a dual monitor setup which I have the extra monitor set as the main one and the mac itself as the secondary (other one is bigger lol). BSS is open always and I try to keep it the only thing open on that monitor but at times I have to move things over it such as Outlook 365, Chrome browser (most up to date version always). While working I have been in Outlook checking emails, searching sites on the web, viewing the project in Chrome preview window, using TextEdit for copying text from various docs to strip extraneous code (which doesn't work for crap lol), and I believe that's all I have had running or been doing while I've been working on this site. Email and Browser are about the only things I've been doing since it was working so I'm not sure what if anything of this might affect it, but the information may help.

Thought I'd bump this up because it is definitely still an issue. I've been trying really hard to reproduce it, but it just seems totally random. I've clicked on every part of the area for the item that should be showing the "Show" or "Hide" buttons, but it just shows the Text Editing buttons no matter what I do once it starts doing that. Can't change pages, can't do anything other than shut the program down and restart it.

Happens quite often once it starts. Sometimes it takes an hour or so, sometimes it's within the first 5 minutes, sometimes it doesn't happen. Just so random I can't get any idea what's causing it or if we're doing something that triggers it. It's kind of hard to tell exactly how long before it happens too, because many times I'm multi tasking and will work with something, then change to something else, then get interrupted and go back to it a half hour later etc. All the while the app is running of course, just not always in the area that something such as Tabs or Accordions will be open or be being edited.

Anyways, just a bump to make sure this is still a prominent issue to be checked on.

In version 2.6.1 we rewrote the logic behind the Toolbars and all of these issues should now be resolved.

Yaaaay can't wait to check it out!

NOTE: I was able to do this 2 days ago when I created tabs 1-4, but today I couldn't access or edit tab panes 2 - 5 (#tab-2, #tab-3, etc) today in the editor. I can access the first tab pane same as always.

I just updated to the latest version and now I am not able to display my tab panes in the editor in order to edit the content.

I tried deleting and recreating but it will not allow me access to editing the tab pane.

I can drag components into the overview, just can't access them after that.

As a work around, I used custom code.

Thank you in advance. ~bb

DISCLAIMER: :) I'm new, so it could be user error, but thought someone could try to see if they are having a similar issue. I'm tired today, but can't believe I was able to create and edit 4 tabs on 4/2/17 and not 4/5/17. lol

PS: Loving how much typing this software is saving my fingers! Great product, thank you.

Are you using the menu that shows up at the top middle of the screen to do your editing? If not then that's why. If so then hmm, not sure what the deal is there. I just opened a project that I have tabs on a page in and I can get to the edit area just fine by using the menu at the top after clicking the tab I want to edit. Just click "Show" and that tab's content is then visible. Working for me just fine here.

Thank Jo,

When I click Show, it makes the tab "active" and makes it the default tab. This caused me issues initially (somehow I had multiple active tabs!) and I surmised it wasn't for editing, it was for determining which tab is the default tab.

Is it an editing option or a active tab selector? Both! I guess I was thinking either/or. Thank you.

I just tried it and it opened the content, but also included the tab pane content from #tab-1 ! May be because I used the "custom code", but it showed up in the preview also.

I don't want to mess with it anymore today as it is working with the custom code workaround. I think I understand it better now.

Thank you for your super fast attention/answer to this!


I thought I'd bump this just to say THANK YOU to Martin and the other devs for fixing this issue. This is the type of thing that keeps me using this app and knowing that it's only going to get better with time. I like also that it's more selective in that you need to select a specific area now to activate it, that helps a lot with explaining it too.

Thanks so much for fixing this, it's been awesome since this update!