What version of JavaScript is supported - Can I use ES2015 ?

I am looking to build a website with the latest version of JavaScript es2015.

I would like to use babel to achieve this.

Can you tell me what version(s) of JavaScript are supported, and also how I would add support for other versions of JavaScript.

Thanks