A few bugs since the last update

MacOS Big Sur w/M1

  • visual preview goes all gray (background color of project). If I save it it stays that way, I’ve had to pull out some saves to get my work back a few times this past week due to this issue. Rebooting the app does not fix the issue, the project is still messed up if it got saved. At this point when this happens I just bite the bullet and don’t save and I close the app and I know I will have some work to redo when it’s started back up. The problem will start up again pretty quickly if not right away after restarting the app. Restarting the computer will usually fix this for a while.

  • editing some areas of text the background turns all white behind the text and if the text is white I can’t find the letters to edit. Moving my mouse around and clicking in other places of that area fixes it for that text, but it will happen next time every time … but not always right away at boot up of the app,
    Rebooting the app does not fix the issue. The problem will start up again pretty quickly if not right away. Rebooting the computer doesn’t always have any effect on this either.

  • selecting text or items to copy: the text will select, but when I hit ctrl+v it deselects the text usually before I can even hit the V and I have to do it over. Rebooting the app does not fix the issue. The problem will start up again pretty quickly if not right away. Rebooting the computer will usually fix this for a while.

  • this one was reported in a separate thread but I’ll add it here just in case. I still cannot close the project after booting up the app for the first time after a restart of the computer. I have to close the app itself. I have seen that I think the project “is” actually closing, but it doesn’t reflect that on the screen, I still have to close the app and restart it to continue working. After this it seems to be ok.

I think something is messing with memory or something, just a guess. Just that the first 2 issues are acting that way. I shut down my computer almost every night and at most it is 2 days max that it may be running, but usually not. Not long enough to be accumulating these issues I guess is my thinking.

P.S. These bugs are not version specific. They’ve happened on version 3, 4 and 5

Visual preview going all gray - I had that too. If I remeber rightly it was to do with having the body background set to transparent.

Hmm no don’t think that’s the issue here then. I’ve only got a few places where backgrounds are transparent. It happens a lot in the nav when trying to edit some of the links, and none of those backgrounds are transparent.

We appreciate the reports! The first two are difficult to visualize without. If you can post a screenshot the next time it occurs it will help us a lot!

The copy/paste issue is a bit strange. I remember reading that you have the copy/paste shortcuts changed on your computer to use Ctrl instead of Command?

I will try to get screenshots next time these things happen. Of course, like always, every time I report a bug it doesn’t happen again for a while lol. The white behind the text and components does happen a lot though, I will try to screenshot it if I can.

I’m not sure how to do anything for the copy/paste quirk with it deselecting, it’s pretty random and not much there to screenshot. I’ll keep my eyes open on that one and see if there’s anything I can show you. I’ve had trouble for a while not (pre last update) with this, but this last update it has made it really bad.

  • Just want to clarify that when I say copy and paste I mean manually selecting the text. I can do the double click to select and paste over and that works perfectly now. The issue is when I’m dragging the mouse to select specific text that when I let the mouse button up it deselects and I have to do it again and then it usually works right.

Yes I do have the buttons swapped, but it’s a Mac thing so it shouldn’t make any difference, it basically swaps those 2 buttons for the computer itself so anything else usually complies with it. Have not had any issues so far on that part.

The issue I’m having on it has only been around maybe the last 4 to6 months (I’m so bad with time sorry lol) which is why I finally reported it. I hasn’t been there from day one, worked just fine a few updates ago or so. I think I reported it somewhere a while ago too that I was having trouble keeping text selected.

I’ll see what I can do on getting some screenshots.

Hi Jo,

For the copy/paste issue you could try highlighting the text and then right-click and select copy. This will help to see if the problem is to do with the software or not not.

Thanks for the suggestion @Parthe , I’ll try that today and see what happens.

Here’s a couple screenshots of what I’m talking about on the background of selected item turning white. If I move my mouse off the selection it stays white until I click back in and haggle around until it changes or just edit the text if I can and it returns to normal. Doesn’t happen every time, but quite often after I’ve been working a while.

CleanShot 2022-03-23 at 13.13.33
CleanShot 2022-03-23 at 13.14.28

Just noticed that this is also present when I double click any menu item in a dropdown, from the Overview panel.

So it seems that this is “better” but not fixed. I can reproduce it now 100% of the time in Mac, by clicking inside a text area to edit any link (only links so far are doing this on Nav, no where else that I’ve encountered. Drag to the left all the way to the end of the component rather than just the end of the text and it happens.
Just to be clear on the text, you can highlight plain text (such as what you see in the gif in light gray below) and that doesn’t have this issue, only an actual link seems to do it.

Here’s a little video:

CleanShot 2022-04-17 at 10.08.44

Just bumping to let you know with yesterday’s update:

  1. The issue with the copy/paste still is a problem. Happened to me 2 times today so far and I’ve only been on for a couple hours.

  2. The white highlighting when editing text is still an issue.

The white highlighting happens because of this Bootstrap CSS:

If you override it and set a different background-color on focus, the issue will be solved.

1 Like

Yaaay thanks Gabby, not sure why I never thought of that, but I didn’t so thanks much for saving more of the hair on my head! :slight_smile:

Also wanted to add that, I’m not sure what you did in this last update, but it “seems” to have fixed the closing of the projects taking forever or not closing fully issue (last issue from my Original Post). I’ll keep checking it, but so far so good!