Bar to edit text disappeared, text highlight and caret disappeared

Since the last updates, the bar to edit the text, the text highlight, and the caret, keeps disappearing on a particular page.

I am using a MacBoor Air M1 with Monterey OS with Bootstrap Studio 6.4.3

Here you can see it working (both the edit bar which holds buttons such as Bold, Italics, Underline, etc) and the highlighting of the selected text:

Here you can see it bugged (no bar with Bold, Italics, Underline, etc, no highlighted text, no caret): Screen Recording 2023-07-02 at 12.27.40

I selected the text, no highlight, no caret, no bar. Extremely HARD to work under these conditions where I can’t see what I’m doing.

Unfortunately I discovered the bug too late and I saved my project using the latest version.

I uninstalled this version and I tried to open an older backup with previous versions of bootstrap studio but it shows a generic error, something like “Cannot open file.”, no idea why. I’m pretty sure I saved them with that version I tried to open it with.

I can’t open the dev tools in bootstrapstudio to check the error (if any logged).

Any ideas? Thank you.

I can concur on Mac version that the text highlighting has disappeared. I thought it was just my computer being stupid, glad to hear it’s not, but a fix would be nice too :slight_smile:

1 Like

Maybe tag the devs? @gabby @martin

Does this happen in other designs? Does it happen on particular components? If it’s a particular design/component, could you send us the design at so we can take a look?

Just replied to Martin Angelov which answered the email I sent over the weekend.

It is the same paragraph text component which is not bugged on one page of the design, and is bugged on others. The page which has has the bugged component was duplicated from another page.

I made a page a while ago, let’s call it “devlog 1”. Then I started duplicating it over the months. When I reached devlog 6, i noticed the problem, after a month of not opening up the program, and updates (the 2 july ones)

I tried some other project and couldn’t reproduce the problem, but honestly I didn’t try them nearly as much as I work on the bugged project.

Issue fixed in Bootstrap Studio 6.4.4, thanks!