Bug Editing a Paragraph

This is on a MacBook Pro. It has happened MULTIPLE times and is EXTREMELY frustrating.

Typing along, entering text into a paragraph component. There is some sequence of keys/buttons or maybe the speed with which the words are being typed..IDK.. that when pushed deletes everything you've typed since beginning the paragraph edit. I just lost 15 minutes of work..f-ng pissed. This is not the first time this has happened.

I have no idea what the button press sequence is, but it happens on a very regular basis. So much so, that I've started to "save" every few sentences typed. Which is a pain if you forget. Which I just did.

Hmm very strange indeed. I am on an iMac and have never come across this issue and trust me I hit all the keys (and some I don't intend to hahaha) quite quickly so if there were bug in this on the Mac version I am sure I would have come across this before.

  • Are you on the latest version? Most likely, but it's the obvious starting point.
  • What version of Mac OS are you running?
  • What other apps are running when you run BSS. Can you run BSS at startup of your computer without turning on any other apps and see if it still happens? Make sure no other apps of any editing, bookmarking, copy/pasting, etc. are running at all. See if it still does it.
  • Have you tried reinstalling the app to see if that fixes the issue, as we all know how sometimes installations can get messed up.

macos hi sierra 10.13.6 bootstrap studio 4.5.1 no other apps running..there are some loaded in the dock (. underneath) like mail, firefox, and finder..but nothing maximized.

I'm not so sure its a key stroke pattern or sequence. It just happened again. I had just typed a bunch into a paragraph and had stopped to think. Hands hovering not touching the keyboard. And bloop..gone..all the input for the last 10-15 minutes gone and the paragraph reset to the same state as when I entered it via clicking the . It was almost like a timer went off. The "Redo" option was on. Tried clicking it, but the data input was not restored.

FWIW, I do a lot of ctrl-c ctrl-v for copy and pasting since the built in editor doesn't seem to support high light & copy.

If it matters, I'm using a LogiTech blu-tooth mouse.

I don't know either, but I would disable bt and use a hard-wired mouse for a while to see if the problem continues.

Obviously BSS auto saves at whatever interval and how many copies you set it for, but I have never had to use it.

I would start with the mouse.

Some software can be run in debugging mode (by the software developers).

I don't think you have that option.

It would be nice to see what the BSS program saw that caused the text to disappear.

Sorry that you've run into issues! This is the first time I see this reported. It will help a lot of we're able to somehow reproduce it.

So in "Settings" there's an option to do automatic backups. This morning I disabled this feature. Since disabling I have not had issues.

Theory based on my experiences...

When editing a paragraph, you're in the middle of doing something. IE..there's a "Blue" editing ring around the paragraph.

When you're in a blue paragraph, your changes have not been "committed". The commit occurs when you leave the paragraph.

When the auto backup triggers, the save feature only knows about committed changes.

So if you're in the middle of making changes, those changes are dumped and the paragraph reverts to the last know saved/commotted state.