Bug when using a Fontawesome 6 Icon inside a Link inside an inline List Item without any text anywhere

Bootstrap Studio will freeze up and create a hung instance of Bootstrap Studio.exe when you do the following:

  1. Create a new blank design
  2. Add a List Component to the page (the Body or any combination of containers)
  3. Select the List go to the Options panel > List Options > Style and change the List to Inline (UL)
  4. Double click on one of the List Items and delete all the text
  5. Drag a Link Component into that same List Item you deleted the text from
  6. Double click the Link Component and delete all the text
  7. Drag an Icon Component into that Link Component
  8. Double click the Icon and change it to any FontAwesome 6 icon
  9. Double click List Item with the Link in it

The program will freeze.

If you force quit and open Windows Task Manager, there will be a single hung instance of Bootstrap Studio.exe that will have used a very large amount of memory.

It ONLY happens if

  1. There is absolutely no text in the List Item or Link
  2. You use a FontAwesome 6 Icon
  3. The List set to Inline (UL)

If you use a FontAwesome 5 Icon, there’s no issue. If the list is anything other than Inline (UL) it works fine. If there’s any text in the List Item or the Link, there’s no issue.

I’ve also noted that, BSS can become very slow when using the FontAwesome 6 icon library. Often times, once I’ve started using FontAwesome 6, I have to wait 5-10 seconds for the icon library drop-down menu to appear, or for all the Fontawesome 6 icons to load. Sometimes, after I select a FontAwesome 6 icon, I have to hit the “okay” button a few times for it to accept and close the window. The program is very “laggy” when you use FontAwesome 6.

Image for reference

My system is Windows 7 Home Premium 64-bit


@printninja Just tried it on windows 10 and it was all fine.

Are you sure you followed the steps exactly? An Inline list, with a link, and inside the link a FontAwesome 6 icon by itself, no text at all in the link or the List Item. I tried it multiple times in both Bootstrap 4 and 5, with new websites and existing sites. It consistently hangs on me, and leaves an instance of Bootstrap Studio.exe running after I force quit the program.

I suppose it could be an issue with my machine. It’s a pretty old Windows 7 install, but Bootstrap Studio is pretty much the only program that ever freezes up on me.

I have a new Windows 10 machine that will be up and running by the end of the month, so I’ll be able to test it on 10 soon.

Thank you for the report! We were able to reproduce the problem. If time permits we will fix it in our upcoming update.

1 Like

I just tried it using the exact steps, worked every time. I was using Windows 10 Home 64-bit

Tried it again and still works fine with no problem.

I can only assume it’s a Windows 7 related issue, since the devs were able to confirm it. :person_shrugging: