Buggy (flickering?) image/object/settings selection screen

Throwing out a bone here hoping someone already figured this out since I can't find the culprit.

The issue is that whenever I open the image selection dialogue or the settings dialogue, it starts flickering and if I maximize Bootstrap studio, then the dialogue often disappears totally with some smaller artifacts.

A short video showing the issue https://imgur.com/a/5ct4X9b

  • My current OS is Pop-OS 19.10 (had the same issue on 19.04 and Fedora 30)
  • Kernel
  • 4k screen using 200% scaling (tried disabling scaling but issue still remained)
  • Amd R9 nano gfxcard
  • Bootstrap v4.5.3 (.deb install)

Have Conky running on desktop which I suspected could interfere but killed that process and tried Bootstrap again with no improvement.

Any idea?

Whenever I see aberrations like this, my first thought is, "update the video card driver." Or in some cases, you may need to roll it back to an older version. It looks like a video driver issue, not a program issue.

Yeah that's what you could suspect if I was running Windows but no other program i'm using behaves like this.

Didn't cross my mind before but I tried something simple after your reply. I turned down the resolution to 1920x1080 and scaling back to 100% and presto! no artifacts or missing graphics.

Guess Bootstrap Studio for Linux isn't tested or suitable for 4k resolution?

You'd have to contact the developers to ask. I'm not familiar with 4k hardware on any platform. I'm still running monitors at 1920x1080. Is there a real noticeable difference going to 4k? The 4k monitors are still kind of pricey.

Yeah it's quite noticeable, everything is crispier and more detailed. When people argue about dpi on a (by comparison) tiny screen on their cellular device, they often forget that you will notice it alot easier on a computer screen. E.g later Samsung phones have 500+ dpi while iphone's go from 326 and up to 458dpi on their XS models while a 32" 4k monitor can have a dpi of ~137.

There are of course more things to take into consideration when comparing cellular device screen and a computer screen but thats for another discussion. A 32inch 4k Samsung U32H850U as example costs around 500euros which is definately pricier than fullhd screens but not as pricey as when they first were introduced to the market.

Either way it's great when working with various graphical tasks

Never had this problem before, but 100% it's your issue like software/OS or some drivers, so ye

@DickyKreedz Do you have a 4k monitor?

Sorry for joining so late! We've tested on Ubuntu 19.10 but no such issues were observed. We don't have a configuration with Amd graphics though. It's possible this is the culprit.

Since Chrome runs on your system with no issues (or at least you haven't mentioned it being broken), this means that the problem will resolve itself when we upgrade the Electron framework Bootstrap Studio is based on, in one of our upcoming releases.

You might want to try running the Appimage, and if this doesn't help, search for any possible settings of the Amd graphics driver on Linux that might work around the problem.

No worries! I've had this issue for some while now but haven't bothered to ask around earlier :)

Have you tried it on a 4k monitor though? It's possibly related to a resolution higher than 1920x1080 (or thereabouts) and if I minimize the window enough, then I get no artifacts so that works for now.

Yeah Chrome and every other app runs fine without artifacts.

Tried the Appimage but no dice, same thing happened.

I can manage for now anyway, just have to live with a smaller windows when working with Bootstrap Studio. I'll wait for the Electron update and try again, if there's anything else that could help you find the cause, just let me know