Cannot Import Custom Bootstrap Theme [fixed in 4.3.5]


I spend a few hours trying to understand this issue. I cannot import a custom theme in a project using bootstrap 4.1.x. Even bootswatch themes do not work. For example, I save this css:

which is the official cyborg bootswatch theme. I import it in Settings>Themes. I then have two possible behavior:

  • I have an Invalid CSS: This file contains invalid CSS and can't be imported error, or
  • I can import the theme, but the software does not switch to the new theme or allow me to save the Setting window.

I am using BSS 4.3.4. I tried reinstalling the software and deleting the local data in AppData to no avail. I tried other themes (non bootswatch) with the same results. I made sure to use bootstrap 4.1 themes.


I would like to add that I was able to import my custom theme a few days ago. I just realized that BSS has automatic update. Is it possible that something broke?

More info: It does not work even if I import the bootstrap.min.css exported by the BSS when I export the website. Is there any way to downgrade the software?

I'm having the same problem. I did some themes, but after the 4.3.4 update, the Bootstrap Studio no longer allows saving the theme. It simply ignores and does not save the chosen theme. I can import the theme but do not apply. There is some way to go back to the previous version.

Thank you for reporting this issue! It has been fixed and we will release a new bugfix update (4.3.5) shortly.

We just released 4.3.5 and this bug should be resolved. Looking forward to your feedback.

Thank you very much for the prompt service. Running normally now

It looks like it works! Thanks.

Awesome feature ! Just imported my first custom theme. Thanks Bootstrap Studio ! What a game changer....