Cannot install update [fixed in 5.0.3]

I have posted this yesterday (02/13), I am not sure why it's gone. Did someone delete it? If so, for what reason? Anyhow... here it goes again.

It is not possible to update BStudio 5+ when you are at the new startup window (that shows you the Recent Designs). When I check for updates at this window, it shows me that there is a new update, but when I click on Install, nothing happens. I have to create a new blank project and then do a check update and install it.

  1. Open BStudio, but do not create a new design or open an existing one. So now you are at the startup window that shows your recent projects.
  2. Do Help > Check for Updates
  3. The popup at the bottom right will show that there is a new update
  4. Click Install
  5. Nothing happens and the update will not get installed.
  6. Create a new empty project and check for updates again. Now you can install the update.

I had this with BStudio v5.0.0, but when I created a new design project, I was able to install the update (5.0.1). However, now that I have 5.0.1 installed and there is an update to 5.0.2 I am not able to install it regardless whether I am at the startup window or I create a new empty project. When I click the Install button, nothing happens. Restarted the app, but I get the same result. I am not sure why is this happening.

BStudio v5.0.1 macOS 10.14.6

I have this same issue. Nothing happens when the Install button is clicked. I update to 5.0.1 by going to the download link I found in the forum but feel uncomfortable doing it that way because it state you must first unintall before installing. I do not want to lose any components and even though I risked it the first update I prefer not to have to uninstall before installing.

I emailed support. I am on Windows 10 Bstudio v5.0.1

Actually now the link page does not say you have to uninstall so I tried again and was successful. I did not lose my components so I guess this is the method I will use until the button gets fixed or something else.

Thank you for reporting this issue! It appears that the update notification doesn't work when triggered using the "Check for Updates". It does work if the notification pops up automatically when the app checks for updates by itself. This is done a minute after the app starts up and every few hours after this. We will fix this in the upcoming release.

For now you can just wait for the app to tell you that there are updates, or restart it so it checks after start up.

It does work if the notification pops up automatically when the app checks for updates by itself.

Actually this is incorrect. I have tried this on my MacBook Pro which has BStudio 5.0.1. Opened the app and waited for the update notification (for v5.0.2) to popup. After about 30 seconds it did popup. But when I clicked on the Install button, still nothing happened. I have tried this twice. Anyhow, I can update it by downloading the full 5.0.2 package and for now it works.