Corrupted .bsdesign [fixed in 4.1.6]


When I tried to open my project today, BSS was refusing to open it, giving me the error 'An error has occurred while reading this design. It can't be opened'. I have properly closed the software after saving via the shortcut; and then made a copy of the .bsdesign after it was done writing. I'm suspecting that the saving thread is also forced to stop when the software is closing, this would explain the sudden corruption. Fortunately I had a backup from a few days back, but it still makes a lot of work to be redone. The software really needs auto-saving!

The corrupted save can be found here.

The laptop has been turned off in the meantime, but as I mentioned, the software was closed, and the .bsdesign isn't changed since the closing of the software.

I hope you can pinpoint the issue, and fix it in the next version.

Kind regards, MagicLegend


yesterday i bought the Bootstrap Studio and worked all night long on a design. Today i wanted to open my Project and it says ‘An error has occurred while reading this design. It can’t be opened’.

This is a joke right?

After saving a lot; I have encountered this bug for the second time; it will just display a blank canvas. The overview still shows all the elements, and the preview function still works; but the canvas is blank, the html bar is the default empty page again and all the CSS is gone.

Save can be found here

It would be nice if the save could be restored in a way.

Kind regards, MagicLegend

@MagicLegend i can open your ".bdesign" file without any Error! But cant open mine xD

@trycon Which one? The first or the second one? The second can indeed be opened; but the first one keeps refusing here...


@MagicLegend you are right sorry.. first one isnt working!

Thank you for reporting this issue! We found what is causing this and will fix it in the upcoming release (probably later today).

In the mean time, you can send us your broken bsdesigns via email and we'll fix them so they can be opened. You can see our email here.

Hi Martin,

Good to hear that it is fixed. I'll email you guys in a bit. Thanks for the support!

Kind regards, MagicLegend

Thanks! Email sent!

Mail sent. Thanks a lot.

@MagicLegend, an autosave-feature wouldnt have helped with this issue. I "autosave" every few steps, depending on how much changes i made, with [strg + s]. My workstation always keeps the last 8 versions of every file. Even the last 8 versions of my .bssdesign wont open. But besides that, an autosave is a good idea.

This issue is resolved in Bootstrap Studio 4.1.6 that was just released. You can upgrade right away and open your designs.

Our apologies for this bug.