Issues with inserting Shift + Enter line breaks

bug 1: cannot delete the line break ... at all So I've been playing around with this to try to find a way to easily remove them. So far I cannot find any way to do this other than to replace the content it's attached to, completely from scratch.

bug 2: cannot copy contents to a new paragraph (drag from components) and insert copied text from a paragraph that had one of the manual line breaks in it. It's like it's copying that line break even though I stop at the end of the line of text. I even tried copying the text to an external editor and then copying it from there into a new paragraph, bu it still inserts that line break on you. When you copy the text to an external editor, there's no way it should be still reading that line break in it. Another issue on this is that I fixed one by doing a brand new paragraph and copying directly from the source website, which seems to be the only way to get rid of them, and then I duplicated that paragraph. I then copied the text from the text editor and pasted it into that duplicated paragraph which never had the line break in it. The line break then showed up again.

Sorry these are so late coming after the update from 4.1, but I haven't really been using them until today. Another issue with the drag and drop which I posted in another thread caused me to need to work with these for a bit instead of the drag and drop component that I created and usually use as they are customizable, hence why I am finding these issues today.

On a side note, we also need a way to edit these line breaks we're adding so we can make them visible at specific breakpoints like any other element. Right now we can't do anything with them at all once they are added. It's like the app doesn't really recognize that they are there other than to allow us to select them in the HTML window, yet it's not really just selecting that, it's actually selecting the entire content of what the line break was attached to. You can see that in the Preview window even though the HTML window shows only the line break being selected. Not very helpful this way, but it's a start!


I can't manage to reproduce bug 1. I can delete safely all line break. Is this an OS specific bug ? (I'm on W10)

I can't reproduce bug 2 too, or I don't understand it. When I copy / paste a text with line break in it, it's fine. It's just placing 2 lines break : one on top of the text and another one on the bottom. But I can delete them without any problems. OS specific too I presume

I'm on MacOS High Sierra, sorry forgot to add that. Been trying to remember to do that when I post issues.

And nope I can't delete them no matter what I do, unless they are placed as components separately as I usually do it and will continue to do until this is solved.