Nav "active" status

This might be working as intended, but just in case I am gonna put it here.

I’ve wondered for a while why a nav item that has “#” in it, or nothing, always shows up as “active” and there’s no way to remove the “active” status, it’s locked in. If I put an actual link in it then it works as it should and the active status goes away, but if I take it out it’s always “active” which means the nav looks goofy with multiple highlighted nav items.

Just wondering if it’s supposed to do that as it doesn’t seem like it should be.

Hope you had a wonderful Thanksgiving if you celebrate it!

Ya that shows up but it’s not activated there so it can’t be turned off. I’ve tried turning it on then back off but that doesn’t affect it at all.

If the navbar has smart active state enabled all links that point to the page will be active, Don’t use that on a one page website

You can turn it of in the options on the actual nav item. If it’s a linked nav then you have to unlink the nav on each page then go through each page and add the active option for each page.

image

Let me be a bit clearer here. I have already been through all of those settings and all the “settings” say it is off, but when you look at the HTML it is active and the color is changed in the nav item as if it were active. There is “No” place to turn this off. Here’ Let me show you:

After I made that reply, I’m thinking … is it like this on export too? I will check that either later or tomorrow as it’s time to make dinner.

Had it open and decided to just do it first lol, and the results are … the same on export so it’s still not right. I was hoping it was just a preview issue … darn LOL

Já aconteceu comigo, precisei desativar toda os itens do menu, salvar, fechar o BSS, reabrir e ativar um a um, mesmo assim teve uns que reativaram, refiz o processo e funcionou.
Também precisei acertar o destino de todos os links.

Yeah I tried that too @gilmar but that didn’t work for me. The only thing that fixes it is if I put a link in it (which isn’t ready to be there yet), or I take out the hash tag #, but then there is no link and there needs to be soon.

It’s just not right, if it’s off in all the settings it shouldn’t be on in the HTML, and visa versa.

I don’t think it’s supposed to do this, doesn’t make any sense that it would, at least not to me.

I’m pretty sure you have the smart active state enabled on your navbar. Highlight your navbar and look at the last option in the navbar options. If the snart active state is enabled then you will not be able deactivate or activate your hash tags links. disable the smart active state on the navbar and you can activate or deactivate your hash tags links as you wish

Sorry I totally missed your response @kuligaposten.

I’m not sure I understand what you mean. I can turn off smart active state and nothing is on in it. There’s nothing to turn off they are all off already.
When I turn it back on, anything with a hashtag in the Link component’s URL becomes active in the HTML only. According to all other settings they are off. Am I missing something in what you said?

My main point here is that they should not be shown ON in the HTML since they are OFF everywhere else. Makes no sense.