None of the *Interactive* controls working on table.html

I’m using the table.html from a template. The control to choose how many records on the page doesn’t work, the search doesn’t work, Page 1,2,3, doesn’t work…What am I missing? Do I have to add JavaScript to make these controls work?

What template did you use? I mean, it’s hard to help you without knowing what you are using. Can you give a link to the site? That would let others help you best.

Template: sb admin
Page: Table - npidatasource

Ok, thanks for sharing that. From what I can see you didn’t finish it. You have no links on any of the dropdowns or pagination telling them what to do or where to go. I’m not sure how the dropdown works so it may be something other than links you need there, but the pagination for sure needs links. Pagination is usually superficial where you would finish all the links to all the pages you want it to go to on one of them, then just paste linked to the rest of the pages and they will all be done. You’ll have to remove the old paginations from each page of course and then that should get that working.

Hopefully someone can chime in on what’s missing other than what each should do. Could be a js file or something, but from looking at the code, there’s no paths or commands telling each one what to do. The choices are all the same.

So, to recap, your items are not broken, just not finished :slight_smile:

I appreciate the feedback! I thought that the templates could/should be pre-wired with methods and events. :grinning:

Take a look here

Now that’s what it’s supposed to look like…Can you share the source with me so I can make that happen?

Was it just the addition of these libs?

script src=“”>
script src=“”>/script>
script src=“”>
script src=“”>
script src="/assets/js/script.min.js?h=09ef9c0d20a48edc03cd55629e90d5b8">

You are the man!



you can download the bsdesign it’s maybe easier

1 Like

I tried your download link and it opens a page of gibberish for me rather than downloading something. Is there something special we need to do to download the file?

EDIT: Never mind, I figured out you have to right click the link to save the file. Might be a Mac thing since I’m on Mac, not sure, not the first time I’ve seen that when I was trying to download somethign though. Thanks for the share Kuli, I"ll match this up to the one I’ve been using and see which is best. :slight_smile:

Kuli’s link worked fine for me. Might be a Mac thing. I know very little about the new Macs, other than they seem to do everything their “own” way. lol.

Could be a Mac thing, no idea, but as long as I know that if I see that for download links that I need to right click and choose to download it that’s fine for me.