Problem with Export

Lately, I have been having a problem with the Exporting of my files. After clicking on Export, my files are exported as they should be, but BSS 4.1.4 locks up totally and I can't close the Export dialog box, therefore I am unable to use BSS at all. So, I have to go into Task Manager and end the BSS program.

This never happened before and just started recently. Any ideas? I'm using Windows 10 build 16299.309.

Haven't had this happens but I would suggest trying

Remember to do the backup part so you don't lose any of your components.


I did all that you said plus the directions on the reinstalling-resetting page.

I tried the first part with no success. Then I uninstalled and reinstalled BSS. Still no success. After Exporting the created website, BSS still locks up totally and has to be ended by using the Task Manager to end the task.

Any other ideas?

Are you using an export script? Are you exporting a lot of images?

Possibly trying exporting to a folder on your desktop rather than a remote server, if that's what your doing.


I'm only using the Export button in BSS.

Yes, there are hundreds of images, but this is the same amount as I had before the problem started. This is a recent problem that started after the last update of BSS to 4.1.4. The only real difference is that I added a lot of AOS scripts.

I only export to my hard drive, never to a remote server.

Ok, if that's the case, then lets try to really narrow it down. I know this will be a bit to do but I'd say go through your code and undo the AOS changes and then export to a new folder so as to not override your current project. Then lets see if it still hangs. If it doesn't hang, then I'd think it is directly related to the AOS stuff in someway. At which point you may need to submit your project to the DEVs to see if there is something broken with it having all that added AOS stuff.



I didn't have to undo any AOS code since whenever I do anything different, I always save to another file name.

For instance, bbfi-2018 (BS 4).bsdesign (no AOS code) and bbfi-2018-aos (BS 4).bsdesign (original before adding AOS code).

So I just loaded in bbfi-2018 (BS 4).bsdesign which has no AOS in it and tried exporting. Same problem. A total lockup of BSS. Therefore, AOS is not the problem.

Hmmm, the only other thing I can think of to try, is to save your work and close out. Open up and only start a new project drag in a couple components and try exporting that. If that works then it's related to the other project for whatever reason. You'd need to have the DEVs check out the file then.

Beyond that I can't really think of anything else to try. Sorry :(



I tried what you said and with a new project, I dragged components to it. I tried exporting and no problems. No lockup of BSS.

How do I go about letting the DEV's check out the file? I guess I would give them the bbfi-2018-aos (BS 4).bsdesign file.

Looking through some of @martin 's reply posts, one of them gave the URL of the Contact Us link above in the nav. Which doesn't have a file upload input so I figure they want you to use the email address and email directly.

I'd said that in your email, mention what the problem is and give a link to your forum post for this issue so they can take a look at why we came to this conclusion. Also since both of the files have this problem. There must be some underlining issue with your non aos file as well so include them both I'd think.


Oh, as another thing. "When" you get the fixed files back (I can't tell you when that would be, don't know). You should save them as something with -fixed.bsdesign in the file name so it'll be separate from any other of your other files. Once you've verified that it is fixed then in the app I'd say use SAVE AS and save over the top of the old file name so that the old one gets the fix and if something does go wrong you have a spare backup of the working file you received back from the DEVs.



I've spent half of today going through my site in BSS. I found quite a few images and other things that are no longer used in my site. I deleted all of them and checked and rechecked the site through preview. Each page looked fine. So I did an export. Six seconds later, the small popup showed saying my design was exported. I clicked cancel and all was well, no lockup. I repeated this a dozen or more times. I even closed and restarted BSS and tried exporting a number of times. No more problem.

It seems that the old images (almost 100) and some various scripts caused the problem. From now on I will make sure that I delete old images, scripts, etc. that are no longer used. It looks like my site needed a Spring Cleaning.

If this had not worked, I would have emailed the DEV's. It was driving me nuts!

Thanks for the suggestions Saj. Your second suggestion was part right. Too many images and some old scripts that no longer were used must have caused the problem. Therefore, if anyone else has a problem with exporting, try to clean up the site and get rid of any images and code that is no longer needed. If that doesn't work, try the other suggestions from Saj. The one about dragging the components into a new project helped me to figure this out with a lot of trial and error.

Good to hear you got it working again and glad I was able to help in someway :)