SFTP not working in latest Bootstrap build.. Please help

after it is fully entered into software , and then publish clicked it sticks on publishing… Is this normal ?

It isn’t very clear from the title, did publishing to that particular site work in previous versions of the app? If it used to work previously but now it doesn’t, can you send us a screenshot of your Export Settings?

1 Like

This is first time I have tried to publish with program.

As a test you can try exporting your website and then uploading it manually with FIleZilla to see if everything works. After this try publishing from Bootstrap Studio again.

1 Like

bootstrap still not really publishing site, but after export and filezilla they worked but not bootstrap studio… I using version6.4.3 is this an issue?

Export Settings.

And FileZilla SFTP Settings…

The Program Just Published to my from BootStrap Studio… I didn’t do anything different, but now it published… Weird…

Just now noticed it did publish the second page nor did it fully publish index.html / links.html… wierd…

I have the same issue.
I am new to B.S. and never used SFTP from B.S. with positive transfer of data.
I use PHPStorm’s SFTP and keyagent with no problems for years to the same site.
PHPStorm is the one of standard software for web dev. I think B.S. have issue.
For now I managed to export to PHPStorm project from that is automatically transferred to desired web site by PHPStorm auto transfer on save. Please describe what key version you require and make failure more useful for troubleshooting. Tell why is failing if possible.

1 Like

I’ve never had any issues with the SFTP in BSS.

The directory field in BSS is the path to the public HTML directory. If you test your connection in fileZilla, have a look in what directory you are connected to. If you are not in the public directory and have to click in the folder structure to get there, then you need to set the right path in the BSS directory field. On a shared hosting the path normally looks like this
Check with your hosting provider what the path is to the public directory.
If you publish to a subfolder that directory must exist on the server

1 Like

Just confirming in Mac also no issues with uploading. I have multiple clients that I upload to different servers with and they work fine.

1 Like

I have found since I am new to this B.S.S This might help others.
Version 6.4.3
Steps I took so far.
1.)Start with new web page .
2.)Import older web pages.
3.)Import any and all code or css pages.
4.) Create full directory structer of old web site .
5.) Move the old web site files into there proper directories in B.S.S.
6.) Run a preview of newly rebuilt website.
7.) Once preview works.
8.)The SFTP Custom Setting, and test connection.
9.)The publish thru B.S.S.
10.) Sadly this always fails…
11.) Try Exporting to local folder and SFTP via FileZilla.
12.) This works, but not perfectly.
13.)When exported , and the Filezilla published it missed files so far. from the export.

One of the big things that recently changed in the last year in Fillezilla is that it needs to have the full directory info and that is the same with BSS. This has usually been the culprit that has stopped people from getting it to work. You need to make sure it is as follows:


The “home” part may be different for your hosting provider, but that is how it needs to go in. Used to be we could just put /index_html, but it doesn’t allow that anymore, it needs the full path to the publish directory for the Default remote directory setting.

Not sure if that’s you’re issue, just pointing it out in case it is.

1 Like

Thank you for the info, we are investigating the problem. Do you mean that FileZilla fails to upload all the files as well?

1 Like

No FIleZilla up loads what is presented, and If I copy them from FileZIlla to server same effect for each web page built with B.S.S …

Add me to the list, too. On my AWS Lightsail as a virtual server, so it’s the root of the URL. Works fine with Filezilla using a .ppk, just hangs on publish from validated SFTP in BSS. 12mpbs upload stream only idling at 45kbps.

Publish does work. After seeing a comment about Filezilla using the full path, I copied FZ’s target line to the publish setup and well, yeah, it works fine and fast. Please excuse my stubbornness.