SFTP Not working on 6.6.1

I updated my studio to 6.6.1 and previously working SFTP configurations stopped working. I have checked paths and permissions but for one of my examples nothing has changed other than the bootstrapstudio update.

No local firewall rules (tested) impacting the issue. Filezilla and putty connections to the SFTP / SSH servers work without issue.

Path is correct and I have tried multiple variations of them just in case but no success.

I do get the error toast popup when running the Test Connection.

Sorry that you’ve run into issues! To jump right in:

  • Which OS are you running?
  • Did all connections stop working, or specific ones?
  • Which firewall/antivirus system are you running?
  • Can you include a screenshot of the error?

OS: Windows 10 22H2
OS Remote side: Debian 16.04 LTS or Ubuntu 22.04 LTS

Yes all connections stopped working after the latest update. I updated the day before without issue for a project without issue. Rebooted the app for the update and it has not worked since…

Windows Defender is all I am running locally. I tested disabling local firewall, adding exceptions for the btstudio folder.

My suggestion would be to try copying your ssh key to a different folder temporarily, clicking the Browse button in the connection edit screen and picking the new key. This is in case Windows Defender has started blocking file access to the existing ssh key.