Trouble connecting BSS to CloudFlare (Custom Domain)

I recently finished a project in BSS and I've been trying to connect my custom domain to it for publishing purposes. However, even after following every step provided by both BSS, BSS videos, and CloudFlare I have come to a rather frustrating issue: BSS will not recognize the connection I've made in my DNS records. Below are two images, one from BSS with the error it continues to show me over and over again, and the other from the current DNS Records section of my CloudFlare account. I'm not exactly sure what I've done wrong but I did a little research on Youtube to confirm then steps I have taken; the video I used as reference can be found here:

Not exactly sure where I went wrong but I'd really appreciate a swift solution to this, thanks in advance.

IMG 1:

IMG 2:

This is an issue you really should take directly to support. The support here is mostly user based not always developer based and support may need more personal information in order to help that you should definitely not put on a forum. Hope you find your issue soon!

Just in case, did you make changes to the DNS records? Is it a new domain? DNS records can take hours to propagate. Domain registrars typically state possible 48hrs for propagation. Maybe that's something that's happening, not enough time yet.


Hi @hotsaucedaddy,

Have you been able to resolve the issue above, and if so, would you be willing to share the steps you've followed? I am experiencing the same unfortunately.

With kind regards,


Hello @hotsaucedaddyy and @rfromthecastle,

Were you able to figure this out? I am having the same issue as well.




I got the website published while using the www subdomain ( in the Publish UI, but it is not letting me publish at the root domain name (no subdomain, just



Hi @erikthejohn,

I was eventually able to publish to my domain (but only using the www subdomain as in your case). I had to wait a few hours for my DNS record changes to be recognised by Cloudflare.

With kind regards,


Just wanted to mention this thread where we solved this problem. Basically the www version is a different website than the root domain, so you will need to redirect one to the other in Cloudflare's control panel.

Hi everyone, I am having the same issue. I published my website when I was in college. But now that I have bought bootstrap studios, BSS can't seem to connect with cloudflare. However, My website is still up and running so Cloudflare's DNS is setup. I just can't seem to edit my website. Can anyone help, please...


Hi, Ok, so I played around with my Cloudflare DNS. I found out that I have a DNS name: content: But BSS is not verifying and connecting to this DNS.

I can't seem to upload a pic here but I wanted to upload my picture of BSS saying "this domain is not available". Please help me with my problem...

Eureka! I have solved half of the problem. I added another DNS: CNAME, www. BSS happily connected with that DNS. So, I can go to and that works fine. However, BSS is not connecting with DNS so I can't update and republish to domain without www. BSS says "this domain is not available". Can anyone help me please.