Unable to remove manually added line breaks

So although the new system of adding line breaks using the Shift + Enter works pretty slick as long as it's not the end of a line, I'm not having any luck working out how to remove them. I'm sure I'm just missing something obvious, but if so can someone tell me how to remove them please? They are targetable in the HTML, but when you target them they are actually targeting the entire Paragraph or H tag etc rather than just the line break so you can't remove them directly. I've tried backspacing, delete, etc. but all it does is either nothing at all or deletes the entire item the line break is attached to. Figured I'd ask here first to see if someone knows what I'm missing before posting it as a bug in case it's not lol. Thanks!

Nope your not missing anything. This is part of the discussion we had a couple weeks ago about Line Breaks. Your not able to get to the side after the line break you can only enter content before it. Only if the line break is entered with content that comes after it will you be able to back space it out.

It's why I suggested that you enter your content first then go back and add line breaks. Or just stick with the Custom Code line break that does infact show up as an element in the Overview pane that you can select and delete. Which I believe the SHIFT+Enter should be have like as well.

The custom code version is selectable and moveable.


Yeah that's what I "was" doing (adding content then adding line breaks after as we discussed in the other thread), but for some reason I'm having an issue with dragging and dropping at times where it just doesn't do it and I have to restart the app/project so I've resorted to adding some manually with the Shift + Enter combo thinking it was actually adding a separate component similar to the ones we created for ourselves to use, but that's not the case at all since it's actually attaching them in some way to the items we're adding them into. Even when they are in the middle of a sentence they don't let me back space them out. Instead it is separating the text so that it's almost like 2 parts of separate text boxes so there is no actual space in there that I can get to to remove it.

Don't get me wrong, I can get them out, but ... means I have to copy the text to an external text editor/notepad, delete the entire sentence or heading, then create a new one and add in the text again. Lots of steps to get rid of a line break.

Also one reason I need to get rid of some is that I duplicated some sections of pages to use elsewhere so I could use all the formatting that was already there ... but I went to remove the line breaks and that's where I realized I couldn't do it and now I have to track them all down and get rid of them ... :(

I hear ya :) I gotta do the copy paste things as well. I tend to copy into NoteTab Pro first then copy into the app to clear out any formatting that may have gotten copied as well. I haven't ran in to the drag/drop thing yet that I'm aware of but I'll let you know if I do :)

I guess it would be a nice thing to have if when you paste that there's a prompt to include formatting as well, a little Yes/No option.



As I said in another forum post, your problem must be platform specific because I don't have this problem.

You're working on MacOS right ?

Yep, MacOS High Sierra. Thought I put that in the post above, but apparently I forgot :/

Is there a way to delete a line break at the end of a paragraph. If I hit shift enter it adds two line breaks ? I can delete one with backspace but not the other.

Sounds like they broke it in Windows format? I’m on Mac High Sierra (soon to be probably Big Sur when my new Mac Mini gets here) and they fixed this issue some time ago on my end. I can put my cursor at the beginning of the line right after the line break and back space to remove it.

Also it is only adding one line break when I use the Shift + Enter combo, not two.

It updates for me when I click outside the text box (or whatever you’re entering it in). Hope that helps.

Ok by trail and error if you add a line break using shift-enter it adds two line break(s). I can delete the first with the backspace key. The second one requires adding a span and then double clicking before the span and hitting the delete key. (Windows 10) This deletes both the span and the line break.

Ok sounds like an issue only with the Windows version then. Mine only does one linebreak now and it’s deletable with a backspace so working as intended I believe on Mac version.


try alt-shift-enter that gives you a new paragraph no line breaks.
If you are on the last blank line and the do alt-shift-enter then you get a new paragraph with the second line break delete the new paragraph

I think though that the issue is he’s trying to just do a line break, not a new paragraph. This issue used to be there when they first added the ability to do the shift+enter line breaks, then they fixed it … I thought. Fixed for Mac anyways.

Thanks for the tip on making a new paragraph on the fly though, didn’t know it did that and it does work in Mac yaaay! :slight_smile: