Version 4.0.0 is out!

Hey guys! After nearly two months of development, I am happy to report that we've released Bootstrap Studio 4.0!

The biggest highlight is, of course, Bootstrap 4 support. You can create new designs in Bootstrap 3 or 4. If you open a design that you've made in BS 3 you can convert it to 4 from the File menu.

Other feature in this release is that we upgraded the Electron framework that Bootstrap Studio is developed in - this brings support for new CSS features like CSS Grid, blend modes, object fit and more.

Bootstrap Studio will notify you about the new update automatically. If you wish to speed up the process, click the "Check for Updates" link in the menu.

Be sure to report any bugs that you find. This was a major rewrite to many parts of the application and some bugs could have slipped through.The next release is going to be 4.0.1 in which we will ship multi CSS block selection and a few other minor features that weren't ready on time.

Congratulations !

Awesome - well done folks - had a play earlier and seems fine and dandy ?

Hi, i tried to convert my BS3 project to BS4, but for some reason only header is converted, the rest of the elements are lost, and not converted...

Also most items are not working properly in BS4, for example the Nav or Navbar item...

Great job guys. Am loving the "Card" component and the new spacing. Big thumbs up here :-)

I think its time to update the main site. ;-)

Thanks for the feedback guys!

@Linux_master can you send us the bsdesign file to our email address (you can see it on our Contact us page)? It will help us improve the upgrade tool. What problems with components are you observing? Is this limited to Bootstrap 3 or 4 designs?

Hello and congratulations for the new 4.0 version. I had an issue through the upgrade. I download the new version through your website, the proper one for my Laptop is the 64 bit, and installed it. When I open the Bootstrap Studio it stuck at the upgrade process for a long time. I also try to uninstall it and reinstall it from the very beginning but nothing at all. I also try to turn off my antivirus and check the firewall too through the process, but still nothing. Any ideas please?

Thanks in advance.

Congratulations! Many thanks to all Bootstrap Studio Developers!

Greetings, and congrats on the new version. During the upgrade on my Mac, the upgrade took along time. After what appeared to be to competition of the upgrade, the screen came up with "Service Unavailable". When launching the new app, I get a dark screen with text only.

Screen shot available, if needed.

We had an issue with our upgrade system which is now fixed. Can you try starting the app again? If it doesn't work, can you try following these steps:

For macOS: ~/Library/Application Support/bstudio path does not exist.


Fixed the issue! To resolve the issue I performed the following task.

1) Re-installed version 2 2) Performed the following action outlined in 3) Had key resent to me in email 4) Installed new version 4 5) The version asked for the key 6) Life is good

Conclusion: If you upgrade, and don't backup your ~/Library/Application Support/bstudio before upgrading it, it gets removed.

I am happy for the v4.0 - but how did I missed the v3 ? Last time I checked it was 2.7 ?


I think there is another bug, when exporting, popper.js it's not being called for BS, and if you are using dropdowns, modals, or similar, you'll need popper, also BS won't allows to place any JS file before the bootstrap.min.js file and popper needs to be first than that.

I have installed version 4 and when I open a project made with the previous version, the "Custom Code" module does not allow to select text to copy. I have the Windows 10 version in 64bit

In addition, the program produces the following JavaScript error: "A JavaScript error occurred in the main process Uncaught Exception: Error: objet has been destroyed at WebContents.eval (eval at callFunction(c:\program Files\Bootstrap Studio\resources\electron.asar\browser\rpc-server.js:249:18), <anonymous>:1:85) at emitMany (events.js:127:13) at WebContents.emit(events.js:204:7)"

I hope you can give me a solution. A cordial greeting Antonio

hi, I can't run the last version, I have the same problem (for macOS), black screen. I reinstall the v2 and don't work, the message of the screen "Please install a newer release of Bootstrap Studio" ,help please!!!

Weird. Yesterday it worked great. This morning I removed the old app and I had issues.

Renamed that folder and reinstalled. Got prompted for lic key and all is working.


@linux_master, I created the following topic for your issue. And it includes what I found in my testing.