Version 4.1.3 is out!

Hey folks!

I am happy to report that we've just launched Bootstrap Studio 4.1.3. The major new feature in this release is full SASS support! You can read more about this, including how to set it up here.

Looking forward to your feedback.

I updated the studio immediately after the notification mail came. I'm using it right now and it is working. Of course, I have not enough time to inspect but this is a huge update. The problem is; when I use UI prepared elements, I need to write everything which are inside the css files into scss. It would be awesome if we could change - for example- background color from styles menu. We need to copy the whole css and paste inside the scss then change the colors or other stuff.

In addition, if you can add prettier beautify color highlighter etc. it would be amazing. ( I'm so sorry, my English sucks :D )


Excellent, thanks. I'm eager to explore the new features

IT WORKS. After you install and configure it.

Well, my first comment is that i like it. Now I will probably write my SASS code in atom and past here. It's really a pity that the editor windows is not detachable. But I do really appreciate SASS support. Is there a list of the SASS editor features supported? Autocomplete like Emmet?

Good work guys, I'm testing the app right now and I'm asking how can I use the Bootstrap (official) mixins, variables, etc ??? Thanks

YAY, finally SASS support has landed.....what a major update!

Thanks guys for you work :-)

Great work Martin and co I look forward to using and exploring the new features ?

Hello! Super excited for the SASS support!

Pardon my being dense, but I am struggling to get bstudio-sass installed and am trying to figure out what is wrong.

  • I have updated Bootstrap Studio and I have installed node.js on my computer (mac).
  • I have run the "npm install bstudio-sass -g" command in the terminal, and that installed just fine.
  • When I run the command "bstudio-sass" in terminal, I get the following error:

fs.js:928 return binding.readdir(pathModule.toNamespacedPath(path), options.encoding); ^

Error: ENOENT: no such file or directory, scandir '/usr/local/lib/node_modules/bstudio-sass/node_modules/node-sass/vendor' at Object.fs.readdirSync (fs.js:928:18) at Object.getInstalledBinaries (/usr/local/lib/node_modules/bstudio-sass/node_modules/node-sass/lib/extensions.js:128:13) at foundBinariesList (/usr/local/lib/node_modules/bstudio-sass/node_modules/node-sass/lib/errors.js:20:15) at foundBinaries (/usr/local/lib/node_modules/bstudio-sass/node_modules/node-sass/lib/errors.js:15:5) at Object.module.exports.missingBinary (/usr/local/lib/node_modules/bstudio-sass/node_modules/node-sass/lib/errors.js:45:5) at module.exports (/usr/local/lib/node_modules/bstudio-sass/node_modules/node-sass/lib/binding.js:15:30) at Object.<anonymous> (/usr/local/lib/node_modules/bstudio-sass/node_modules/node-sass/lib/index.js:14:35) at Module._compile (module.js:662:30) at Object.Module._extensions..js (module.js:673:10) at Module.load (module.js:575:32)

Apparently, a file or directory is missing? But I am not certain what or where. Any ideas as to the error here? Did I miss a step? Was I supposed to create some sort of destination/folder? I've followed the directions to a T so far, so I am having a time trying to troubleshoot this.

Thanks for your time! -Zach

Hello! im having the same issue on macOS, how did you fixed it?

Thanks in advance.