Vertically Aligning Table not fully working [FIXED]

I started a thread here, but although I was provided with lots of work around (thanks all for that), it’s still not right so if you can look into this it would be great. Here’s the original thread:

The issue is the Align-Middle BS5 class for vertically aligning tables does not carry through outside of BSS. In BSS it vertically aligns as it should. Outside it does nothing. The only way I could get it to work was to create the class in my CSS and add the “tr” to the class as shown in the other thread towards the bottom. That thread also states all the different ways I tried to make it work.

From what I see in BS5’s table information this should work by applying the “align-middle” class to the Table element (not to be confused with the parent div of the table).

It is because you are using simple dataTable which comes with css that override the classes you have on the table tag

1 Like

I’ve just changed every vertical align (which I have a lot of the classes in that file commented out since I don’t use them) and still nothing.

I’m looking in the Styles window right now and the “.table” default BS5 class has it’s section in there with the “vertical-align: top” in it and it’s active so nothing in that file is apparently affecting anything.

Very strange too because I thought I was using your component, but apparently not. May have to think about swapping it over if it’s possible to do without losing all the data. Ugh

omg all this time, I still have no clue what was wrong with that file, but I changed it over to yours @kuligaposten that you added for me a little while back, added the align-middle class to the “table” field and it now works as it should.

Gonna go through that file and see just what was causing the problems, because its not in the CSS so it must be in the js or something. Gives me something to do LOL.

Thanks everyone for all of your help! Very Very appreciated!

No Software bug here in the end after all! Sorry for not finding it before posting :confused: