What am i doing wrong(Force State)

In BSS, I get this when I try and replicate some code i created in Codpen
It’s just a simple change of background-image on hover.

It works in BSS preview and publish, but in the editor, I get this and under the Force State tab, I have to toggle off :hover to see the hover effect.
UPDATE :slight_smile:
It probably has something to do with the order of my CSS rules. Will see if I can rearrange the blocks
Nope, makes no difference

I guess that’s because, while editing the :hover pseudo class, BSS forces the hover state so that you can see what you’re doing. You can always toggle it back on, if you need to adjust the :hover settings.

Thank you. That makes sense.

If you haven’t done it yet, you need to add these images to the project, if you’ve already done that, it’s likely that the image name or extension is incorrect, I tested it here and it worked fine.

you have a space between the class and :hover so it will give different results

Looking at and replicating the original code from charlene, it seems like a bug in bss

My images are there.
When I select the div with the images, I get this, the effect isn’t visible in the editor:

When I click on any other component the hover effect is visible

I noticed that you don’t have the tab Force State in your image

Thank you, I noticed this error when I went to preview the site, I was lazy, kkk.

I didn’t use any of that, I just did the direct css, by default it displays the default image, and the image when moving the mouse only in the browser view.
When I forced the state, I got the same result, maybe BSS can’t display this.

Thank you @richards and @gilmar I thought it was weird. It’s a simple few lines of code. Thought I was missing something.
@martin any thoughts

Thank you for reporting this! We will fix it in our next update.

1 Like