Bootstrap Studio 4 (64bit).exe (Windows 7 and above) not starting up.

I just have download the Bootstrap Studio 4 (64bit).exe (Windows 7 and above), then install it. On startup I enter my newly purchased license key and change the default PC hostname to a suitable one and then submit. An error message comes showing a message to try after some time. From that moment every time I tried to open bootstrap studio, it hangs on at the startup screen where a loader is showing for an infinite time.

Then I uninstalled the app, installed again but the issue remain the same.

Would you please someone let me know what is going on and how can I fixed this issue.

Note: I use my license key to one of my iMac today and this is my second PC running windows 10.

Thanks in advance.

I'll ask the first obvious question ... why are you changing the PC Hostname, or more precisely, what does that mean? I have not ever had to change any hostname for running this app so I'm not sure what you're talking about. If you can elaborate a bit more it may help.

You may need to contact support to help you on this issue as well in case they need to walk you through how to do a clean uninstall to try a reinstall.

Undoubtedly, the BSS installation is somehow associated in the Window's registry with the name of the PC. When you changed the name, it probably made BSS think it was no longer installed on the same computer. Either contact support and find out how you can do a clean uninstall of BSS, or you could try using CCleaner to clean out the registry entries that were left over after you uninstalled BSS. You might also be able to do a system restore to a day before you originally installed BSS, then change your hostname FIRST and then reinstall BSS.

But I would contact the devs first.

Hello Jo, thank you for your reply. Actually you know there is a text field named "Name This Computer", if this is the case then why did it ask me the name of my computer? BSS can use it by default without asking to enter anything. As there is an option to change the name, I changed it which is obviously did not match with my computer name. I thought that this might be an issue.

I searched a lot then find how to uninstall the app going through this link. Then I keep the computer name as it is but without any success. It says that "An error occurred while validating your license. Please try again.

Hello Printninja, I can find any support link anywhere in the website except Contact Us link. I send a message to them but did not get any reply from them. It is frustrating that in weekend I am not able to work in my home which I have planned before purchasing the BSS. My weekend which is precious to me for working is going in vain.

Have you tried the most obvious solution? ... rename the host back to the original name? See if that works while you're waiting on support to answer you. :)

Yes, I have tried that too without any success. I did that in 2 different ways.

First of all I use CCleaner for registry clean then uninstall the app following this guideline in and keep the PC name unchanged in the license validating screen, I got the license processing error.

Secondly I change my PC name, then restart windows with a different PC name and keep the name unchanged in the license validating screen and got the same error. It seems that I can not use my license in other PC where as when purchasing it said that I can use the license in 3 different workstations.

N.B. I am using the same license in my iMac without having any issues. Would you please someone help to find a solution?

I think you're going to have to wait on Customer Support for this one, I do hope they don't make you wait all weekend, let us know what happens though if you would please. :)

Did the program ever work on the Windows machine (meaning, before you changed the hostname?)

Sounds like it never worked.

You should be able to free up your bum Windows license slots using your Mac BSS working install.

On Windows, you might want to try a System Restore to get to a clean pre-BSS install point (if you have to).

Sometimes programs won't run because Windows is missing critical updates. I have no idea what is happening without being at your location.

Virus software is known to sometimes interfere with installations. Also, on some occasions I have had to use the Compatibility Checker, but I don't think I did for BSS.

Just a few suggestions.

Sometimes programs won’t run because Windows is missing critical updates

An annoying Windows 10 phenomenon, which is why I refuse to upgrade.

An annoying Windows 10 phenomenon...

I've even had it happen on Win7 x64 Home Pro.

And micropuke won't tell you why certain software won't run... you have to be smarter than the computer and sometimes micropuke.

But I've spent 3 years programming MacSEs and Mac IIs, and the rest of the time on PCs. So I'm very familiar with PCs.

But a good chunk of my life is with mainframes and midrage computers. Kind of unbelievable how much things have changed.

I have a Windows Server 2016, which is also a Windows 10 machine. It is what it is.

Thank you all for your reply. I am surprised that BSS support is not replying me. What should I do now. I can not uninstall my current windows version as it has a lot of application installed and so many thing configured as I am a full stack developer working on embedded programming too.

I do not think that the bug is unknown to BSS. They should know what is going there. They should have log, error reporting into their server. They should respect customer query and to solve it, at least a positive message what is going on.

If I can not use a product after purchasing and the support team is not taking any action to solve it so please tell me any of you what should I do now.

Best regards,

The developers are usually very good about handling support issues, so I would either write another message to them, or wait another day. Sometimes they can take a day or two to respond, but they don't monitor this forum on a daily basis. This is a user forum, so you have to contact them directly to get support with things other that what other users can help you with.

I already mentioned that I know only one email to contact to them and have their reply about the link to completely uninstalling the BSS, which did not work.

Then I send 2 different emails to them and waiting to know what should I do.

Have you tried emailing the developers again, or gotten any response yet?

Hello guys! It's like Christmas day to me :))

Finally I managed to activated my bootstrap license key with the help of Bootstrap Support team. I can't wait to share this with you all guys. The solution is as follows:

Bootstrap Support reply:

It's possible that a firewall or a router is preventing the app from communicating with Bootstrap server. If possible, can you try restarting your router or connecting from a different network, like a hotspot from your phone?

I then stop my Windows Defender firewall and connect my PC with mobile hotspot and magically it works :))

Thank you all for your kind reply and support.

Hardly magic. It's pretty much common sense that you have to disable or add exceptions to your firewall when a programs has to access any type of non-local location. The reason nobody suggested it sooner is because it's common knowledge in 2019.

But good that you're finally up and running. Enjoy the program.

I disagree with you Printninja, as because I did not face any type of issues in my way long IT career related to Firewall for all other application without knowing by the app. What is common is a pop up from Windows saying that the particular application want to access my internet connection. It is more common than silently know nothing about what is going on in the background and showing a message that "Try again later"!, isn't it funny!!

I might say the app (BSS) itself should be able to detect that it failed to connect to their server or threw an exception about the firewall issue. Why do I need to stop firewall to use a specific application, is that safe, you think?

Try adding the app to your firewall exceptions? I had to do something with that on my Mac whenI first installed it. Course, Macs are good about giving you pop up warnings ir dialogs with choices when your firewall is blocking something you’re trying to use :P