BSS adding breaks everywhere

Hi - I’m working with BS5. I’m finding that BSS is often adding <br /> to several elements. After headings, after paragraphs, after list items.

I can see the breaks in the code editor, and they’re in the exports too. However in the WYSIWYG editor, there is no evidence of these breaks - I can delete and backspace to my heart’s content and there’s nothing there. But it is in the code.

There’s a ton of clean-up to do after an export. Anyone else having this issue?

If I was to guess, it seems like a copy and paste issue - it doesn’t like me pasting in text from somewhere else, even if it is Notepad…

Edit: To give an example: I can copy a heading from Notepad (i.e. no formatting whatsoever), and paste it in an H2 tag, and it will add <strong></strong> around it and add a <br> afterwards, and there’s nothing I can do unless I delete it and write the heading from scratch. Not a big deal for one heading, but for a blog with many paragraphs, headings, lists etc…

break

Many thanks.

This seems to happen in BSS regardless of the version of Bootstrap (not just BS5.) BSS is not a text editor. Clearing the </br>'s manually is just something you get (or at least I’ve gotten) used to doing. :man_shrugging:

Hmm OK, thanks.

I think this is a legitimate bug and pasting in text should happen cleanly - doesn’t need to be a text editor for expected behavior on that level.

I’d like to humbly put this forward to be fixed. Otherwise, how can you publish changes direct from BSS without repeating the clean up every time for every page? Kinda somewhat negates some excellent features. Lots of love for BSS.

Hmm, I’m on Mac version which may make a difference on this, but I don’t have this issue at all. The only time I get breaks added automatically is if I copy and paste text from something other than a raw text editor (such as directly from email, from Word or equiv., from a website page, etc.). Then I usually have them and that usually cues me to remove it and start over using a raw editor instead in case there are other hidden styles in it. This is of course typical expected results so it’s not a BSS issue.

Other than that, it works fine for me with no extra breaks.

Understood, thanks.

However, in terms of being a BSS issue, could it be said that it might be a BSS for Windows issue?

I don’t know if it’s a Windows issue, but in 12 years using 5 different Windows website builders (though one was cloud-based) I never found one that cleanly imported text, and striped away all formatting from other programs like Microsoft Word, Adobe InDesign, other website builders, or even text copied off the internet. Copied text just always seems to carry over some formatting, line breaks, etc… I don’t necessarily blame Bootstrap Studio for this. I think the program is simply pasting the text as it happens to be formatted.

While I agree it would be nice if the program did this “cleansing” itself, I don’t really expect it to. BSS is not a word-processor, or desktop publishing program. Long ago, I got into the habit of pasting any text I copied from a foreign source into a plain Windows .txt file, which typically removes all formatting. Then, I manually delete all the line breaks. When I do this, and paste the text into BSS, it pastes in perfectly clean with no </br>'s anywhere. It’s an added step, but I don’t consider it that big of a deal because I’ve gotten so used to my workflow, and I only feel comfortable using text from a foreign source by “cleaning” it via the method described above.

Of course, when I type directly in BSS, I never encounter any formatting issues.

That’s the thing though - I am copying from a Windows text file (Notepad) with no formatting of any sort. I think if one goes to that trouble to strip it it away, then it should be a working option, ideally.

@Plutarch

If you press Ctrl-Shift-v when you paste your text you will not have the line breaks. if you have a line break under the text that you want to delete. click at the end of the text and press Alt-Shift-enter that will create a new heading or paragraph with the br in it. then delete the new one.

I get an extra </br> break even when I paste with Ctrl-Shift-v. See the attached image. That is simply two lines of text in a Windows .txt file separated by a single carriage return.

When I highlight it, copy and paste it into a BSS using Ctrl-Shift-v, I get the results you see in the image. BSS sure seems to be adding an additional </br>

Do you get the same results if you use a different text editor like notepad++ and the like? Maybe check that and see if it’s possibly a windows issue?

Same thing in notepad++ (see attached image.)

Dunno if it’s a Windows issue or what. As I said, I’ve just gotten used to deleting the extra </br>'s

Thing is, you don’t even need to copy 2 lines. Copying one line or partial line (a few words) will cause the same issue. Don’t see it being a 3rd party format issue then, as there is literally nothing to be formatted line-wise in what you are copying.

Yep is definitely a BSS in Windows issue then as I don’t have that issue ever anymore. However, I did have it a couple years back when we all complained about it, but I guess the Mac version must have gotten some love that Windows didn’t get somewhere along the line.

Hopefully it’s addressable yet, as that would drive me crazy if I had to deal with that every time.

I should note that I’m on Windows 7x64. I don’t know if this is a WIndows O.S. issue, a platform issue (Mac vs PC), or a BSS issue.

But it’s definitely an issue the devs should be made aware of. @martin

Thanks. Yes, I’m actually getting mixed results with further testing of copy and pasting. I should temper my previous statements by saying sometimes it happens, sometimes it doesn’t. I should identify the exact behavior before formally requesting anything. But my previous exports have been littered with breaks even with clean attempts, so something is going on…I will get back to this thread after more use over the weekend.

Ctrl-Shift-v always works for me, Ctrl-v add line breaks but is easy to delete

If you have a line break under the text that you want to delete. click at the end of the text and press Alt-Shift-enter that will create a new heading or paragraph with the br in it. then delete the new one.

Are you on Mac or PC?

PC, Windows 10 Pro x64. Haven’t tried Linux yet.

Still trying to pin the exact behavior. One thing is for sure - the breaks cannot be deleted by any means within BSS once they are there. Can only be removed manually post-export in a code/text editor.

I’m on windows 10 when I made the video

Thanks - I will test that over the weekend and let you know if that fixes it. Thanks for going to that effort for the demo.