Copy / Paste text inserts two new lines

When you copy the contents of one label or any other text in a control (double click on control, CRTL+A to select all and CRTL+C) and then in the same way paste it in another control the program inserts two new lines, one before and other after, this error is very annoying.


Paste using CTRL+SHIFT+V and this will not happen.

Also, you can refer to this post, where the issue has been discussed at length…


Copy/paste of text using only CRTL+C is standard for all editors and this is the right way, add the SHIFT key is not intuitive, you should change this.

About the CTRL+SHIFT+C combination, I think you wanted to say CTRL+SHIFT+V (paste)


Yes, I made a typo. I meant CTRL+SHIFT+V (thanks for the catch, I’ve edited my post.)

And yes, I agree the CTRL+SHIFT+V combo is totally non-intuitive, and not used in any other software I’m aware of. It’s kind of the way Facebook makes you use SHIFT+ENTER to create a line break.

Jumping back and forth from various social media websites, to programs like Bootstrap Studio, and then to Adobe Illustrator, which each use different keyboard combos, can become confusing. I often find myself using CTRL+SHIFT+V in Illustrator and wondering why nothing is being pasted, until I remember I’m not in Bootstrap Studio.

I have no idea why ordinary CTRL+V results in added line breaks, and so far, the devs seem to have kept silent on the issue (probably because it’s a fairly minor thing, and they’re working on some significant additions to the software right now… I believe involving e-commerce.)

I don’t know why people think that a HTML tag <p> is a text editor. In a <p> tag one use <br> for line breaks if you don’t want to see the line breaks copy your text into a textarea component and you can use CTRL V to paste your text and you will not see any <br> in the textarea:

If you include tinyMCE or similar you can have your textarea as an text editor

The behavior of both CTRL+V and CTRL+SHIFT+V is, in my experience, random and unpredictable. If I highlight and copy the content of my post directly above using CTRL-C and paste it into a <p> element in BSS using CTRL+V, I get the following:

If I paste it using CTRL+SHIFT+V, I get the following:

If I first paste it into a Windows .txt file, I get the following:

If I highlight and copy the text from the Windows .txt file using CTRL+C and paste it into BSS using CTRL+V, I get the following:

If I highlight and copy the text from the Windows .txt file using CTRL+C and paste it into BSS using CTRL+SHIFT+V, I get the following:

There is no rhyme or reason to how this works. In the first example, all the <br>s were removed from the body of the text, but one was added before, and one was added after. In the other examples, no <br>s were added before or after, but multiple <br>s were added in between the paragraphs, regardless of whether I used CTRL+V or CTRL+SHIFT+V.

I have given up on trying to figure out how/why BSS formats text pasted from outside sources. I simply go in and manually edit it after it has been pasted.

I accept that BSS is not a text editing program, but I have 10 year old website builder that has a built-in text editor so that when you create a <p> element and paste raw, unformatted text into it, you get EXACTLY what you copy. No unpredictable or extra line breaks are added.

I think that a considerably more modern and sophisticated program like BSS should be able manage the same thing.

1 Like

In another thread I had said I don’t see this issue at all, but although I haven’t seen the extra visual spacing like above, I have noticed a handful of
that are part of a paragraph and sitting below the text. I looked at them closely to make sure there would be no reason I’d put them there and there wasn’t so I guess I do have this happen periodically also.

I would truly like to know if the Devs are working on this at all. So far there’s been so many complaints about it in the past few weeks + from many different people. There should be “no” extra breaks added to anything that is pasted from a raw text editor such as Windows Notepad, Notepad++ or Mac’s Textmate, yet as we see above they are showing up.

This is a hassle and so far I’ve seen very little reply from the Devs on it other than to give a key combo to use that is not typical for copy and paste. Please let us know if this is planning to be fixed.

You lost me Kuli, I’m asking about fixing the issue of the extra line breaks, not about a rich text editor. Thanks though, I wasn’t aware of there being a rich text editor built in either.

If that’s how you’re supposed to enter text, then what’s the point of being able to double-click on a <p> element? Why not simply have double-clicking a <p> element open the internal rich-text editor. And if an internal text editor is the best way to enter text, then it should be a robust rich-text editor like this one…

I prefer to click the components myself and edit them there. I don’t like “rich” text editors, they tend to muddy up the code most of the time and it would add steps to have to pull the styles out into a CSS sheet after editing all the time.

Now if it is able to do clean code, same as double clicking the components does, and it gives you the option to add your styles to specific classes as you go, then sure I’d use it, but I highly doubt it does all that.

Once again though, it’s getting off topic as this is about the extra spacing added when pasting text into the components directly. Not sure if it does it within the text editor or not, but the line breaks are the focus of this thread.

When you double-click on a <p> you are supposed to start typing your text and right in front of your nose you can see the toolbar with the available rich textual tools in BSS, you can highlight a word and click the B and the word gets bold. If you want to insert text you are supposed to click the chars button and paste your text where it says Type here…
That will keep the text inside the <p> and you will not get a <br/> under the <p>

If you want to use a custom rich text editor like the one you show in your post then read the section custom code in the Bootstrap Studios Docs.

The short video I posted shows you how to do when you insert text into a <p> or <span> without getting a <br/> under the <p> or <span>

If you don’t like the tip or video, ignore it. Do it your way and be happy