Version 5.0.0 is out!

Hey guys!

I am happy to announce that Bootstrap Studio 5 is now available. This is the biggest update we've ever made. Let's jump straight to the changes.


  • You can now edit JS, CSS, SASS and Custom Code in external editors like Visual Studio, Sublime Text and more. Just right click and choose "Open In".
  • You can convert between paragraphs and headings, divs and sections and more with the new "Change to" option.
  • A new Fit to Canvas option was added to give more real estate to your work area.
  • You can now Show/Hide components from the page helping you iterate on your designs.
  • The start screen was redesigned. You can see many more designs at once and search through them.
  • Added Sub & Sup components.


  • Bootstrap was updated to 4.4.1 and support for row-cols was added.
  • The SASS compiler is now built in and always available, obviating the need for a separate helper utility.
  • The update system was reworked, and you can choose whether to update automatically or postpone updates from Settings.
  • The icon fonts in the app were updated to the latest available versions.
  • The Bootstrap Theme dropdown in Settings now shows a visual preview.


  • Bugfixes and other small improvements that were suggested, like support for Webp images, generating unique id when duplicating elements, support for new CSS properties was added and more.

Bootstrap Studio won't update automatically to 5.0.0, instead it will notify you and point you to our download page. But because we rewrote the update system, this will be the last time this is needed. From now on the app will be able to do even these big updates automatically. This was also a good opportunity to give users control on whether to install or skip updates (you can change this preference in Settings > Updates).

This was a big release, so it's possible (even likely) that there are some bugs we haven't caught. Be sure to report them and we'll fix everything promptly :)

This are great news, where can we download it from?

A big bravo for you guys ! Already love the "Open in" functionality ! Keep going in this direction !

Great, but for ref, when you go to the download page, after selecting the operating system, the download button is disabled.

Tried on Firefox, Chrome and IE..

Thanks for the comments!

Great, but for ref, when you go to the download page, after selecting the operating system, the download button is disabled.

There seems to be a caching issue on the download page. A ctrl+f5 should fix it for you.

Thanks for the update but no support for dual screen?

rbekar at 2:26

I have the same problem, the download button is disabled.

Tried different browsers, tried ctrl+f5

still not working 2020-02-12T15:04Z

Yeah, ctrl+f5 did nothing; that button is broken. I tried it in Firefox and in Edge and got the same behaviour in both. I ended up inspecting the page source to get the links.

Strange. Can you guys check if there are any errors in the dev tools console? It works in all browsers we tested.

Hope Bootstrap Studio don't mind this just to help those having trouble.

Win = Mac = Linux =

Looking forward to testing this out :)

No significant errors. The first two will be because I have Google and Facebook domains blocked in uBlock Origin. The third appears to be advice.

Loading failed for the <script> with source “”. download:11:1

Loading failed for the <script> with source “”. download:1:1

This page uses the non standard property “zoom”. Consider using calc() in the relevant property values, or using “transform” along with “transform-origin: 0 0”.

In Edge I get only the following in the console:

HTML1300: Navigation occurred. download (1,1)

CSS3121: The media query -ms-viewport has been deprecated.

Thanks! The download page should work correctly now.

Hi, I downloaded the new version but after rebooting it asks me to re-enter the license key. I enter my code but the following error appears: An error occured while validating your license. Prease try again.

Thanks you Carmine

@carmine Sorry that this has happened! Can you try reinstalling/resetting the app? You can learn how this is done here:

Seems to be working fine my end, the download links now work as well

I also tried to reinstall the previous version but without success.

Hey Martin,

I just installed version 5.0, thanks for all the improvements:

A new Fit to Canvas option was added to give more real estate to your work area.

Can you explain what that means?, I haven't found this option.


Seems to have a little glitch in the drag to highlight when you are in the Attributes pane and trying to drag from right to left. It can't seem to find the end of the text or recognize it? I can go to the beginning of a word/class/etc. and highlight that way, but not from the end of the line at all. This did work before this update.

P.S. You "can" do this if you work at it hard enough to try to get to the right side of that last character (this is only at the end of the line), but it's not productive in any way.

P.S.S. This seems to also affect the Styles pane where we were able to copy and paste from one class to another in there. Now it is not possible to highlight by dragging, only seem to be able to highlight the actual attribute names or class/id names or attribute values, but not the entire text of a line or multiple lines.

Thanks so very much for all the great updates too, love the "hidden" indicator in the Overview pane, that will save me a lot of hassle with editing the Labels to show what's hidden and what's not, love the external editor too, and so many other things, still testing it so I'll let you know if I find anything else :)

Forgive me, but I have to refrain from downloading this new version until you guys get all the bugs worked out. I'm in the middle of three time-sensitive projects, and I need BSS to be stable for rest of the week, so good luck to all.

Why is there no .deb version for linux? Only AppImage for linux is available! Will there be .deb file for the same soon?